Building Your First Application

For the purposes of this tutorial we'll be focusing on the mechanics of turning an SWF file into an EXE file. In later tutorials you'll find out how to add SWF Studio commands to an SWF file to get at the real power of SWF Studio.

  Open SWF Studio by double clicking on the SWF Studio icon located on your desktop, in your Quick Launch bar, or in your Start Menu.

  Select the SWF file that file you want to use as your main movie and drag it from the file system onto the SWF Studio window.

  SWF Studio will present a Yes/No prompt asking if you would like to make the SWF your new main movie. Choose Yes.

After selecting a main movie in this manner, you may notice that certain settings in your new SWF Studio project have been populated for your automatically with default values. These default values are generated from the name of the SWF file you selected.

The main movie field on the Movie Tab will contain the full path to the SWF file you selected.

The application file name field on the Output Tab will contain the name of the SWF file (without the SWF extension) and the output directory field will contain the path of the folder that contains the selected SWF.

The Title/Caption field on the Window Tab will contain the name of the selected SWF file (without the SWF extension).

  Now you can press the Build button on the toolbar to create an EXE file from the SWF you selected.

Your application will be created using the default settings from the various project settings tabs. One of those defaults means that all of your output files will use a default icon that looks like this:

You can easily change the icon that appears on your output file. Feel free to experiment and change any or all of the available project settings and rebuild your application to see what effect they have on the final output file or use the links below to read about what each of the settings is designed to do.

·  Output Tab
·  Movie Tab
·  Window Tab
·  Application Tab
·  Screensaver Tab
·  Defaults Tab
·  Version Tab
·  Expiry Tab
·  Plugins Tab
·  Files Tab
·  Masks Tab