Posted by desoto0311 in SWF Studio V3 on Oct 14 2008, 02:23 pm

I tried making what I thought was a 'simple' flash movie (in flash CS3,exported as flash 9, AS2) with the demo download of flash studio. I have a few input boxes that you can put numbers in, and click a button to display those numbers in another box. The boxes are pre-populated with "0" (zeroes). The strange thing is, it works fine if you highlight a zero with the mouse, change the number, and do the same with the next text (input) box. IF, however, you TAB through the input boxes to quickly populate them, the next box IS highlighted (the zero is highlighted) but when you type something in, it goes blank, and then if you click away, click back in, etc. you can NEVER type in that box again. I tested the swf and it doesn't exhibit this behavior until it's brought into SWF Studio. Is this because I'm using the demo download or could it be something else?

BTW, I've also tried setting tab index for only the text boxes (textname.tabIndex=X;) but that didn't help either. Other than that, I like the file writing features, and the other options, which seem to work pretty well.


Posted by mbd in SWF Studio V3 on Oct 14 2008, 04:07 pm

Can you post your simple FLA? I have seen focus issues with AS2 components when publishing for Flash Player 9. The easy workaround was to publish for Flash Player 8. However, I can't seem to make it fail in this way - it's possible other components in the Library contribute to the issue.


Posted by desoto0311 in SWF Studio V3 on Oct 14 2008, 06:03 pm

Here's the fla. Okay, so this is REALLY strange now.. (BTW, the fla is not so simple anymore, ugh.) The only frame that now does this is the "procedures" frame (blue background, you'll see), and all the previous frames with input boxes work 'intermittently', as in, when I export the flash file (from flash) they won't work, but if I save as..., then export/test, they'll work?!? (Again, all but the one frame I mentioned, which is frame 14)

Sorry if the file is a bit sloppy. I'm not even testing within swf studio anymore, as that ONE frame now seems to do it even in flash now. I also tried your method of exporting as flash 8 to no avail.

Thanks in advance for any assist!

attachments: k_test2.fla  


Posted by desoto0311 in SWF Studio V3 on Oct 15 2008, 12:33 am

BTW, one more note: I'm not actually using an as2 component. (As can be seen in the fla file.) I'm using homebrew movie clips ONLY, and the input boxes. At this point I'm leaning toward it being a flash-issue, but after tonight I'll have two days of google searching officially logged, and can't seem to find anyone else who has this problem in flash. This scares me.

Help on this would be greatly appreciated.
Thanks again,
-D


Posted by desoto0311 in SWF Studio V3 on Oct 15 2008, 01:57 am

I've uploaded a new fla file. This one is only one frame which should narrow things down. Same problem: If I click and drag inside the input box we're good to go, if I tab to the box, I can't input anything and the input box is essentially 'locked out' from having anything input.

BTW, (and this makes NO sense) when I remove all of the STATIC text from the page, it seems to work fine. Huh? I'm going to double-check that none of the text fields have any strange variables on them (ie some of the static text fields aren't static) but it's doubtful. They were all copy/pasted from each other.

attachments: k_test3.fla  


Posted by MKull in SWF Studio V3 on Oct 15 2008, 12:23 pm

played around with your last fla for a few...

FYI, if I turn off the embedded fonts on the input fields, they work as expected.


Posted by MKull in SWF Studio V3 on Oct 15 2008, 12:31 pm

also , if I leave the embedded fonts, but turn off anti-aliasing, it works as expected. Two workarounds for ya there :)


Posted by desoto0311 in SWF Studio V3 on Oct 15 2008, 01:31 pm

Okay, so I've got this working within flash, but AGAIN, once brought into SWF Studio, I lose my tabbing features. So let me clarify:
There are several frames that have input boxes to 'tab' through. The more complicated page has been pulled from the equation by making it impossible to tab on that page. Not eloquent but I don't have the problem.

HOWEVER, on those pages that I have only a small, simple collection of input boxes, tabbing through them doesn't work when imported into swf studio, so it seems to be on the northcode side of things.

Anyone have any suggestions?


Posted by northcode in SWF Studio V3 on Oct 15 2008, 01:41 pm

What version of the Flash player are you testing with outside SWF Studio? SWF Studio embeds 9.0r47 so if you're testing with a newer version of the player outside SWF Studio then the bug has probably been fixed in 9.0r124.

Send an email with your serial number to support@northcode.com and we'll reply with a link to the latest development build that used 9.0r124 so you can see if that fixes the issue you're having.


Posted by desoto0311 in SWF Studio V3 on Oct 15 2008, 01:54 pm

Okay, so I saved DOWN to flash 7 and the problem is gone. Of course now there's a NEW problem when using the flash print() command:

unrecoverable error: couldn't find library msvcr80.dll
required by c:\program files\TortoiseSVN\bin\libapr_tsvn.dll
please ensure that it is installed

Which crashes the app. I'm *assuming* if I didn't have tortoise installed it wouldn't crash (based on some other posts within the forum) but I guess I don't get how saving down to 7 would affect swf studio. This is too frustrating and buggy for me. The potential is there, and I can see being able to pull off some nice simple application type stuff with this, but to code for flash 7 (old!) and have bugs and workarounds that require fingers to be crossed? I would be way afraid of sending anything to a client for fear that it wouldn't work. (Or worse, that they burned 20k copies into cd/dvd; ouch!)

Thanks for the trial though.


Posted by mbd in SWF Studio V3 on Oct 15 2008, 02:05 pm

The MSVCR80.dll issue was resolved in a previous version of SWF Studio.

1. What version of SWF Studio are you using?

If it works when you publish to a different version of the Flash Player then I'm guessing this is a Flash Player issue.

2. What version of the Flash Player are you testing with outside of SWF Studio?

SWF Studio 3.5 build 314 uses Flash Player 9r47. The latest build of SWF Studio (internal dev build) uses 9r124. It's possible what you're seeing might be resolved in a new version of the Flash Player.


Posted by MKull in SWF Studio V3 on Oct 15 2008, 02:52 pm


QUOTE: from desoto0311;45739
snip/ but to code for flash 7 (old!) /snip

Isn't by that standard, coding in AS2 old compared to AS3?

Did you turn off font embedding? I pulled in your fla, disabled embedding and built it to an exe and tabbing worked fine. Nothing to do with SWF Studio.


Posted by desoto0311 in SWF Studio V3 on Oct 16 2008, 11:39 pm

Strange... I didn't mean to sound like I was ignoring your posts. When I had posted the last three times your comments weren't in there, so I was essentially just putting up my own personal 'follow-up', lol. Okay, so to answer questions:

1.) yes, by my 'standards', I suppose that as2 is "old" compared to as3, however I believe that there are far more people developing in flash9 then flash 7 or earlier, whereas it's hardly uncommon for many flash developers (like myself) to still be in 'as2'-land for many reasons. (Not the least of which is the time involved in 'learning again' while clients still have deadlines.) I won't get into a ******* contest about this, I just think that design/development is 8/9 while AS is still heavily as2 & 3.

2.) I downloaded swf studio demo from a shareware site. v3.3 I believe. I'll download the latest (didn't realize there was something newer) now.

2b.) That being said, I'm in 'trial' mode so I don't believe I have a serial number. That's why one of my questions was if there were limitations (such as certain functions not working) with the trial. I'll guess at this point that it's a no. (Besides the obvious limitations/expiry pointed out on the site.)

3.) After I download the newest version (to potentially alleviate the newest error; DLL) I'll see if that removes the tortoisesvn error.

4.) At that time I'll also try the embedded and/or anti-aliasing work-around(s). (Thanks for that tip, btw.) I REALLY hope it's simply my 3.3 vice newer version, as there is a noticeable difference visually with both embedding fonts and (especially) anti-aliasing. The rest of the layout (static fonts) looks nice and clean, and I'd envision on an actual project (this was just copy/paste b.s. from an existing dental client) that with nice clean graphics/layout, the aliased text would come across as amateur and 'html-y'. I'll look into it.

5.) Current Flash Version: 9,0,124,0 so yes, I'm onboard there.

6.) One other note on the DLL deal. The forum posts that I've read seem to show that people with at least my current version (soon to be upgraded, lol!) are still having dll problems. Am I to assume that 3.(current version; gotta' check, lol) fixed all of that?

Thanks again for all of the quick responses. If only some of the more popular flash boards did the same! ;)


Posted by northcode in SWF Studio V3 on Oct 17 2008, 03:08 am

Just a couple of quick things to mention...

We haven't authorized anyone else to host downloads of SWF Studio (or sell it) so if you didn't get your copy from northcode.com you may have more than just an older version (virus, malware, adware, spyware, etc).

The most current version is 3.5 build 314 and that does fix all the MSCVR80 and related DLL problems you've been reading about that existed in previous 3.x releases.


Posted by desoto0311 in SWF Studio V3 on Oct 23 2008, 03:28 pm

Well that would make sense then. Since the install, the dll error is now happening with non-swf studio programs so I've uninstalled and am now installing my usual goody-bag of freeware spyware/malware/virus detection software (ie clam***, spyb**, adaw***, etc.) so NOW I'm really not trusting any 'unpredictable' results I'm having because I'm sure I'm infected with *something*. Ugh. I've been around long enough to normally not trust 3rd party sites, but since I didn't actually do a search for a specific program (just searched for swf executable file saving) I ended up downloading several 'trial' programs from various sources. It wasn't until I tried out swf studio that I found your website; otherwise I would have downloaded directly from here first! (I know, pitiful excuse for contracting malware in one of the stupidest/easiest ways.)
That being said, I will use 3.5 once I've fixed my computer (or reformatted which is looking likely since my dual-core2 Quad is now running SLOW) and I'm sure these issues I've had will vanish.

Thanks again for all of the help. Again, WAY better than many flash forums with twice the membership. Says a lot about your support.