Posted by sharvey in SWF Studio V3 on Aug 28 2008, 10:22 am

Hi, I searched the forum to solve the ocx problem our client is getting, but it seems to differ from what the others have been experiencing. Here's what happens :

A user with (very) restricted permission runs the exe. The program runs fine and all, but when they quit the application and try to view a web page in Internet Explorer, they are asked to download the flash player. When they do, the animation plays but they have to reinstall flash every time they visit a page.

What we discovered was that the executable seems to change some keys in the registry, referring to the flash ocx.

Before running the application, the user already has the flash player 9 installed by the administrator.

We need it fixed as soon as possible.

Thanks in advance.

Simon


Posted by northcode in SWF Studio V3 on Aug 28 2008, 10:59 am

Whatversion (and build) of SWF Studio are you using? We had a problem that sounded similar to what you're seeing, but it happened a long time ago and it's been fixed for a long time.


Posted by sharvey in SWF Studio V3 on Aug 28 2008, 11:18 am

The version is 3.5.314.


Posted by northcode in SWF Studio V3 on Aug 28 2008, 02:01 pm

What operating system are you seeing this happen on? Can you send us a copy of the EXE to try here?


Posted by sharvey in SWF Studio V3 on Aug 28 2008, 02:21 pm

Thanks for looking into this.
The client's operating system is windows XP sp2. As for the executable, I don't think i'm allowed to put it on a public forum. I'll find a generic version of it and send it to you by private message.
Simon.


Posted by northcode in SWF Studio V3 on Aug 28 2008, 03:45 pm

You may have 3.5 build 314 but the EXE you sent me was built with 3.4 build 222. That explains why you're having issues. Make sure the EXE gets built with the latest version of SWF Studio and the problem should go away.


Posted by sharvey in SWF Studio V3 on Aug 28 2008, 04:29 pm

I'll try that. The only problem is that we have a hard time reproducing the bug, so its hard to know if it is fixed or not.
thanks again. Simon