Posted by mpedersen in SWF Studio V3 on Feb 13 2008, 12:40 pm

So, it seems that there's a very small memory leak, more of a trickle, occuring when I bundle up a .swf file with SWF Studio 3.4.222. If I run this same .swf as a Flash 8 projector, there is no leak. Ditto if I embed the .swf into HTML and run it in IE. So it's certainly a SWF Studio Issue.

The use of SWF Studio is minimal, i.e. I basically use it just to wrap things up, apply alpha transparency (so I can have nice rounded edges), use it to set the system tray right click menu, icons and other general "polishing up" stuff.

So that's pretty much it...just slowly eats a 50 K here, 100 K there...of course if I minimize the memory tied up drops substantially, and when restored it is at a lower level than when first launched, but it creeps a little faster.

NDAs and such, I don't think they're gonna let me share ANY source on this one, so let me know if there's any other info / testing I can provide. FWIW, this seems to have been an issue with MULTIPLE 3.4.222 bundled projects.

Thanks in advance,

Matt


Posted by mpedersen in SWF Studio V3 on Feb 18 2008, 12:56 pm

No one else ever have a slow trickle like this? It occurs only when the .swf is bundled up with SWF Studio - I personally wonder if this is related to the use of alpha transparency...

Matt


Posted by northcode in SWF Studio V3 on Feb 18 2008, 01:20 pm

If you see the memory being reclaimed when you minimize the application then it's due to garbage collection. In V3.5 we found and fixed some small memory leaks in some plugins and core commands (see the items marked as fixed on known problems list). I don't think transparency support was one of the leaky suspects but it's possible.