Posted by uni in SWF Studio V3 on Jan 09 2008, 05:21 am

My files connect to a soap service via web service connectors - however once i rebuild in the beta to see if the hooking dll thing is resolved, my connection suddenly erratically fails, though when i have 2 instances running on the same network but on different machines, one will fail and the other will be fine, and its not always the same one - so there's no obvious pattern.


Posted by mbd in SWF Studio V3 on Jan 09 2008, 09:26 am

You're saying that this doesn't happen with 3.4?

Have you tried testing your SWF locally in Internet Explorer? Does it behave differently? Make sure you have Flash Player 9r47 installed, which is what 3.4 and 3.5 use.


Posted by uni in SWF Studio V3 on Jan 11 2008, 06:33 am

i've got the full version of 3.5 now so been testing over the last 2 days. still getting the odd undefined from the server and still some funnies but haven't been able to detect a pattern yet.

So far, I'm not getting the actual hooking dll error message, but occassionally it's still quietly failing i.e the file just closes and doesn't continue, but it's also not writing that txt error log file, so I'm not sure if its our server or still the dll problem (on my laptop it would also fail previously without telling me it was a hooking dll problem)...
but so far so good, well done guys.
will get back to you when i've done so more intensive testing.


Posted by northcode in SWF Studio V3 on Jan 12 2008, 05:34 am

The hooking DLL error only happens when your application starts (it's an initialization error) so if you're seeing something fail now then it's unrelated to the hooking DLL problem.


Posted by uni in SWF Studio V3 on Jan 14 2008, 08:58 am

Tim I'm glad to hear you say that. It's crashing at startup of the app.
with the new version, my desktop so far (the one that had the dll error pop up error msg) - is so far working fine in that it doesn't bring up the error msg, but my laptop is failing as it was before where it would just stop running and bring up my Visual studio debugger, but my machine is crashing now before i can even see what the debugger is complaining about.

you guys have any ideas what i can do to determine exactly what happens - or why it's happening?

in terms of my getting "undefined" from the server - it's so erratic - i need to run them from exe files so they can do their swap out thing. previously on 3.4 never had this problem.

i know i'm not being very helpful with whats happening, pls advise what info i can provide.

thanks guys.
uni.


Posted by northcode in SWF Studio V3 on Jan 14 2008, 10:07 am

If this is some kind of initialization error it should not matter what you do, the initialization error happens before any of your code executes. So...

What happens if you start a simple application that executes some basic SWF Studio commands (display a message box or something) instead of trying to access your web service? Does that sporadically fail at startup?

What happens if, instead of at startup, you call your web service when a button is pressed? Does it still fail at startup or when you access the service?

Have you tried building with the debug Flash player (new option on the Output tab) to see if any runtime errors are being generated?


Posted by uni in SWF Studio V3 on Jan 15 2008, 04:23 am

ok i found an exception on the server side, had a word with the guy who developed it, he's bug!!!!
will keep you guys posted ... but looking good.


Posted by uni in SWF Studio V3 on Jan 25 2008, 08:29 am

I can confirm that the hooking dll issue has been resolved.
well done guys.


Posted by northcode in SWF Studio V3 on Jan 25 2008, 10:30 am

Thanks for the follow up uni, it's good to have confirmation :)